Commit 5d20f03d authored by Vermeeren's avatar Vermeeren

readme: rework listing available packages section

parent 6c792a20
......@@ -34,14 +34,17 @@ deb-src https://mel.vin/debian/ buster-backports main contrib non-free
The current list of packages can be viewed at https://mel.vin/debian/.
Alternatively, after adding the repository and running `apt update` you can list
the available packages locally with this snippet.
the available packages locally.
```
for i in /var/lib/apt/lists/mel.vin_debian_dists_*_binary-amd64_Packages; do \
printf 'list file: %s\n' "$i"
read
grep-dctrl -sPackage,Version . "$i" | less
done
```shell
# List all packages in buster and buster-updates.
aptitude --group-by none versions '~Averm-buster ~Averm-buster-updates'
# List all currently installed packages from buster-backports.
aptitude --group-by none versions '~VCURRENT ~Averm-buster-backports'
# List all currently installed packages not from official stable buster repo.
aptitude --group-by none versions '~VCURRENT !~Astable'
```
### Repository doesn't support architecture ...
......@@ -65,7 +68,7 @@ The solution is changing `deb ...` lines to `deb [ arch=amd64 ] ...` or similar.
First, install the generic development tools.
```
```shell
sudo apt install packaging-dev debian-keyring devscripts equivs
```
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment